Jump to content
  • 0
BrianW

EvNotify integration

Question

Hi Folks.

Ive managed to get EvNotify, my dongle and betterroute talking to each other (Hyundai Kona EV). The problem is that the Nokia 1 I’m using has a tiny screen and isn’t compatible with Android Auto (but in any case I doubt I could get it taking to the dongle and car at the same time). Is there any way that another device (Apple iPhone) can connect to betterroute so that I can display the live route on the Kona’s screen using carplay? I’ve tried logging into betterroute on another device, but I’m not able to tap into the live data stream. I would have thought that if EVNotify is talking to betterroute, it could in turn allow that data to another connection?

 

cheers Brian

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

 

 Hi Brian,

This is not an answer to your question rather just a general comment.  I would love if you could post some more information about how are you got as far as you did with your integration. Looking forward to your input, and sorry I couldn’t answer your query.

 R

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, BrianW said:

Ive managed to get EvNotify, my dongle and betterroute talking to each other (Hyundai Kona EV). The problem is that the Nokia 1 I’m using has a tiny screen and isn’t compatible with Android Auto (but in any case I doubt I could get it taking to the dongle and car at the same time). Is there any way that another device (Apple iPhone) can connect to betterroute so that I can display the live route on the Kona’s screen using carplay? I’ve tried logging into betterroute on another device, but I’m not able to tap into the live data stream. I would have thought that if EVNotify is talking to betterroute, it could in turn allow that data to another connection?

Android Auto and CarPlay integration requires a standalone app (or some light hacking of your device to get it to display a webpage), so something that's still a ways off for us.  We're working on it though, as we have time!

Any secondary device should get the live data the same way as your primary device, I've done this personally on several road trips so I can leave the car-connected (EVNotify) device in the car while I charge and get notifications when done.  Assuming you've logged into the same ABRP account, it should work exactly the same.  What do you see on the second device when you pull up the Live Data display?

14 minutes ago, Raharney said:

This is not an answer to your question rather just a general comment.  I would love if you could post some more information about how are you got as far as you did with your integration. Looking forward to your input, and sorry I couldn’t answer your query.

Have you run through the setup instructions on ABRP? If you go to Settings > More Settings > Live Data > Setup, it should give you step-by-step instructions to connect EVNotify with ABRP.

Share this post


Link to post
Share on other sites
  • 0

The car play or android auto integration would be great, basically to get the real-time feedback of knowing that ones progress compares with betterroute’s estimation (on that subject, I’ve found that provided consumption is no less than 7.5km/kwh betterroute’s estimation is bang on).

On the Nokia1 I get the view live data lit green, but on my iPad (connected to the internet via wireless) it won’t light up despite using the same ABRP login, that’s all I’d need really, as we could then use CarPlay to display that output (using an iPhone instead).

Basically I bought one of the cheap dongles that the EvNotify chap recommends, plug that in with the car switched off, switch the car on, fire up EVNotify, confirm connection, then fire up abetterrouteplanner.com usually by then it already has the live car data. Next up is to actually test a route.

Share this post


Link to post
Share on other sites
  • 0

I looked up your telemetry on the server, and it appears to be correct there.  I can't say I've tested ABRP on Safari, I don't have access to any iDevices or Apple laptops.  Could you try it on a different device, say a windows laptop / PC and see if your data appears there? That would help narrow down where the issue is I need to fix.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks Jason for the information.

 

I think I have to spend more time playing with the interface, then maybe I wouldn't have to ask so many silly questions ;-)

 

R.

Share this post


Link to post
Share on other sites
  • 0
On 8/1/2019 at 3:15 AM, Jason (ABRP) said:

I looked up your telemetry on the server, and it appears to be correct there.  I can't say I've tested ABRP on Safari, I don't have access to any iDevices or Apple laptops.  Could you try it on a different device, say a windows laptop / PC and see if your data appears there? That would help narrow down where the issue is I need to fix.

Hi. I just had some time to try a few things... both chrome and safari didn’t give live data on my iPad, I tried our Windows 10 laptop and I got live data with Chrome, but not with Explorer, I hope that helps, thanks for an excellent program, I’m constantly telling other forum members about it, I’m impressed!

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, BrianW said:

Hi. I just had some time to try a few things... both chrome and safari didn’t give live data on my iPad, I tried our Windows 10 laptop and I got live data with Chrome, but not with Explorer, I hope that helps, thanks for an excellent program, I’m constantly telling other forum members about it, I’m impressed!

I also just tried it with my wife’s iphone6 (the device we would most likely be using the car), same story with both safari and chrome. Let me know if you want me to try something else...

Share this post


Link to post
Share on other sites
  • 0
On 8/5/2019 at 8:01 AM, BrianW said:

I also just tried it with my wife’s iphone6 (the device we would most likely be using the car), same story with both safari and chrome. Let me know if you want me to try something else...

That is definitely bizarre, I'm not sure why it would fail in one version of Chrome, but not others (desktop vs mobile).  Perhaps try clearing the website's cache and trying logging in again? 

https://www.imyfone.com/iphone-space-saver/how-to-clear-cache-in-safari-on-ipad/

Hopefully these instructions are correct, as I don't have an iOS device.

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Jason (ABRP) said:

That is definitely bizarre, I'm not sure why it would fail in one version of Chrome, but not others (desktop vs mobile).  Perhaps try clearing the website's cache and trying logging in again? 

https://www.imyfone.com/iphone-space-saver/how-to-clear-cache-in-safari-on-ipad/

Hopefully these instructions are correct, as I don't have an iOS device.

Tried again this morning after clearing the cache, same non live connection 😞

7BAB2174-D072-4791-B89E-0F737FB9012F.png

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, BrianW said:

Tried again this morning after clearing the cache, same non live connection 😞

And when you click on "View Live Data" Nothing populates at all?  Not even cyan/stale data? Could you try running this setup:

https://medium.com/@mattcroak718/debugging-your-iphone-mobile-web-app-using-safari-development-tools-71240657c487

And tell me if any errors are being shown in the console when you try to access live data?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 hours ago, Jason (ABRP) said:

And when you click on "View Live Data" Nothing populates at all?  Not even cyan/stale data? Could you try running this setup:

https://medium.com/@mattcroak718/debugging-your-iphone-mobile-web-app-using-safari-development-tools-71240657c487

And tell me if any errors are being shown in the console when you try to access live data?

Not having much luck with the development tools as my laptop runs on Windows not IOS. I’ll see if there is and old version of Safari for Windows that will give the debugging functionality.

 

7545817D-C46F-4CE2-A268-52893AB8EEE6.png

Edited by BrianW

Share this post


Link to post
Share on other sites
  • 0

Sadly the version of Safari that works with Windows doesn’t run betterroute, shame as it has the built in debugging tools!

Share this post


Link to post
Share on other sites
  • 0

Hey guys. Did any solve this issue?

My hyundai ioniq ev is connected with a by odb dongle and is being read by evnotify on an android phone.

I went though the setup to integrate evnotify with a Better router planner. And went ok.

Now in the abrp site the button live data  when clicking on it it gives a up pop with different measures but no data in it. All empty.

Tried from the android chrome browser and iPhone safari.  

Share this post


Link to post
Share on other sites
  • 0

I'm have a very similar issue with Torque.  I have a Bolt EV, so I can't use EV Notify, but with Torque, I'll get it set up to view live data.  I'll sometimes get live data for 1 trip (but that doesn't always work), but the next time I try to use it, no live data shows up.  I can get it to work for another trip by clearing the cache on Chrome, but that causes it to regenerate the user ID to put in to Torque, so I have to go through that set up again.  This has only recently been an issue.

Share this post


Link to post
Share on other sites
  • 0

Well since evnotify integration is broken. 

Can we install the abrptransmitter apk on an android phone? or does it only work on the Headunit?

Share this post


Link to post
Share on other sites
  • 0

I have live data on the phone communicating with the dongle, it’s my other devices that aren’t seeing the live data, only my Windows PC works sees the data remotely.

Perhaps time to invest in some Apple tech so that you can directly develop, you don’t want to leave millions of Apple users out of the equation if you plan to commercialise your product...

Still happy to try stuff for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...