Jump to content

Android Auto Battery Charge

Recommended Posts

I own a 2021 Ford Mustang Mach-E and recently purchased ABRP Premium in order to use it with Android Auto in my car.  I am currently using ABRP 4.0.56 on my Google Pixel 4a (5G). The bug I found is that irrespective of the current % charge I enter into my ABRP app on my phone, the % charge showing up on my in car display ALWAYS starts out at 100% charge and there is no ability to change this through my car's display.  This happens even when I change the % charge in my starting location or when I change the starting charge % in the app's general settings on my phone.  At the very least, my Android Auto car display should pick up the starting charge % from my phone that I entered for this trip.  Ideally, it would pick up the % charge remaining from my car's software.
For example, I planned a trip from my home to my work (about 11 miles) and my car showed an estimated remaining battery charge of 61% and 188 miles.  I entered 61% into the "Starting Charge" in the ABRP app on my phone and saved the trip.  This had no effect on the "Starting Charge" on the ABRP display in my car (via Android Auto) which continued to show 100%.  Note:  The % Charge remaining at the destination showed 98% and I did, in fact use 2% charge (according to my car's calculation) on this trip.  So it appears that the math is working properly.  The display just needs to get the correct starting charge % form my phone, or better, automatically from my car.
Link to comment
Share on other sites


Unfortunately we do not get data from your car directly. If you plan a trip on your phone with a specific SoC set before planning, Android Auto should use exactly that SoC. 

Could you please try to plan a route on the phone and then connect the phone to your car or plan while being connected. You should be able to see the planned route from the phone on AA with the config you had on the phone.



Link to comment
Share on other sites

I have this bug many times where I use the gear icon next to the starting point (My position), hit the plan button, and then my SoC is suddenly at the default SoC in the general settings (which for me is 90%).

As a sometimes working work around, I have to hit Back after entering my SoC and then route from the waypoint list rather than from the #1 waypoint gear icon page. Try that out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...