Jump to content
  • 0
Henrik frog

Connecting to Apple Watch


After upgrading to premium account, I tried to open the app on my Apple Watch. 
I get message that the app for Apple Watch is only available for premium members. 
I tried several times to close the app on the phone and open again, however, still same message pops up. 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0


same issue here ! 

I've upgraded to PREMIUM and after installation on my watch 6 (v7.6.1) , I have the message "open the ABRP app on your iphone" but ... nothing more/nothing works !

I paid and

  • no watch feature
  • no "mytesla" synchro 
  • other missing feature I'm not aware ... yet ?

well ... not very happy.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...