Jump to content

Wrong name on roads with ref (MapTiler bug)

Recommended Posts

Description: Wrong road names on roads with "ref" set, but not "name"
Type: Webpage
Replication Steps:
  1. Visit above plan, and zoom in somewhere on the route. You'll notice that the road (which is Norwegian "National Road 4") is named "Aleppo-Ramadi".
    (The actual Aleppo-Ramadi road is also "National Road 4", but is obviously not located in Norway.)
  2. The bug is that MapTiler (when name is missing) selects the name from another road with "ref" set to the same value.
  3. Bug link: https://github.com/openmaptiles/openmaptiles/issues/762
  4. This is not really a ABRP bug, but an already solved MapTiler bug. But you probably need to update the MapTiler version or something.


Edited by jervi
Link to comment
Share on other sites

Ah, good find. I'd seen a clearly incorrect name on a major road in Scotland and couldn't figure out why. Tried to edit in OSM as thought it came from there but couldn't find it. "A9" (with no other name) is becoming "Trans-Sahelian Highway" (in Africa).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...