Jump to content
Glyn

Live Data From LEAF Spy not working

Recommended Posts

On 6/25/2019 at 6:54 PM, MrThrane said:

You can run it in split screen on your phone. I'm doing that and it's working great. 🙂 

Hm, I can get LeafSpy Pro and ABRP in Chrome up in split screen, but only the app with focus seems to update. I'm on a Moto X4 running Android 9. Any tips or tricks?

Share this post


Link to post
Share on other sites

I'm experiencing problems with ABRP and it's Drive and follow-up mode. If plotting a route with LeafSpy Pro sync enabled, ABRP does not show the 'driving' mode. It keeps saying 'Real-time information when driving' on the drive-mode screen. When looking at the map, you will see your 'navigation pointer' moving over the road. So ABRP does get location data, however, it does not show on the 'drive mode' screen.

 

Share this post


Link to post
Share on other sites
19 hours ago, NootNoot said:

I'm experiencing problems with ABRP and it's Drive and follow-up mode. If plotting a route with LeafSpy Pro sync enabled, ABRP does not show the 'driving' mode. It keeps saying 'Real-time information when driving' on the drive-mode screen. When looking at the map, you will see your 'navigation pointer' moving over the road. So ABRP does get location data, however, it does not show on the 'drive mode' screen.

 

What do you see when you have LeafSpy open in the foreground and ABRP on another device or splitscreen on the Live Data display?

Share this post


Link to post
Share on other sites

Hello,

I've the same issue, no data life displayed.

Connected and old Android phone with BT and Wifi connected to Access Point enabled on iPhone as relay for Internet access.
abetterrouteplanner web site is displayed on Android Tablet and Wifi connected to Access Point enabled on iPhone.

I'm using Leaf Spy Pro and it was running before ID Changed.
Android phone, are configured with LeafSpy Setup on my my account on Abetterrouteplanner.
Note - ID Change each time that I display LeafSpy Setup.

When I view Live Data I've -> Age 4414412

Capture du 2019-07-08 18-04-48.png

Share this post


Link to post
Share on other sites
8 hours ago, kdebarb63 said:

Hello,

I've the same issue, no data life displayed.

Connected and old Android phone with BT and Wifi connected to Access Point enabled on iPhone as relay for Internet access.
abetterrouteplanner web site is displayed on Android Tablet and Wifi connected to Access Point enabled on iPhone.

I'm using Leaf Spy Pro and it was running before ID Changed.
Android phone, are configured with LeafSpy Setup on my my account on Abetterrouteplanner.
Note - ID Change each time that I display LeafSpy Setup.

When I view Live Data I've -> Age 4414412

Very strange, could you send me a Private Message of the webserver logging settings from LeafSpy?  Also, when you try to log, does any kind of popup show up in LeafSpy? Perhaps a semi-transparent text popup that disappears after a few seconds?

Share this post


Link to post
Share on other sites
14 hours ago, Jason (ABRP) said:

Very strange, could you send me a Private Message of the webserver logging settings from LeafSpy?  Also, when you try to log, does any kind of popup show up in LeafSpy? Perhaps a semi-transparent text popup that disappears after a few seconds?

Ok, I will send the settings - I don't see any popop.

 

Share this post


Link to post
Share on other sites
On 7/6/2019 at 3:20 PM, Jason (ABRP) said:

What do you see when you have LeafSpy open in the foreground and ABRP on another device or splitscreen on the Live Data display?

I have send the dongle back to the manufacturer, the connection of the dongle dropped every 30 seconds. Another 'strange' problem occures: when driving with my Leaf and ABRP is logged in on my ABRP-account, ABRP does not show anything in the drive-mode. When logging out of my ABRP-account, ABRP catches a location within seconds and displays accurate information in the drive-mode. 

Does ABRP wait for LeafSpy e.g. to send information? I have LeafSpy off now (because of the DOA of the Dongle). 

Share this post


Link to post
Share on other sites
8 hours ago, NootNoot said:

I have send the dongle back to the manufacturer, the connection of the dongle dropped every 30 seconds. Another 'strange' problem occures: when driving with my Leaf and ABRP is logged in on my ABRP-account, ABRP does not show anything in the drive-mode. When logging out of my ABRP-account, ABRP catches a location within seconds and displays accurate information in the drive-mode. 

Does ABRP wait for LeafSpy e.g. to send information? I have LeafSpy off now (because of the DOA of the Dongle). 

Hmm, it should detect stale data, and revert to "blind GPS" mode, I will investigate this weekend as I have time.

Share this post


Link to post
Share on other sites

@NootNoot - Turns out there was a bug (and it was the "how did that ever work in the first place" variety), and it should be fixed now! I also made it so that browser position will fill in the gaps if the data rate is lower than once every 5 seconds.  

Share this post


Link to post
Share on other sites

Hi,

 

I am start trying to use the live info from leafSpy (on leaf 30kWh) and it is working with some issues.

 

First- The "Speed" and "Power" in the live data tab are always 0.

Second (most important) - The SOC % presented on ABRP is to high and does not match the car dashbord SOC (it is 5% more)

 

If I do not use live data (only estimated) it works better, the estimated SOC is very good.

 

Thanks for the good work.

Share this post


Link to post
Share on other sites

@Frankesousa - Thanks for the report!

Speed - have you tried this while in motion? It should compute your speed from the lat & long positions reported by LeafSpy, so it'll lag, but should eventually provide data.

Power - This is expected. Last time I checked, LeafSpy did not provide power (or voltage and current data) so this will never show data until LeafSpy reports it.

SoC % - This is interesting, several users and I did some work on reverse engineering the displayed SoC from the LeafSpy reported parameters, and we had thought it worked quite well.  As a point of curiosity, does the LeafSpy reported SoC match your dash display? 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Jason (ABRP) said:

SoC % - This is interesting, several users and I did some work on reverse engineering the displayed SoC from the LeafSpy reported parameters, and we had thought it worked quite well.  As a point of curiosity, does the LeafSpy reported SoC match your dash display

No, the maximum SOC reported by LeafSpy (with battery full) is 97.5%.

The reported SOC from leafSpy is the same presented on LeafSpy App and it is less than the dashboard until 50% SOC and higher than dashboard from 50% until 0%

Edited by Frankesousa

Share this post


Link to post
Share on other sites

Ah, interesting.  So the SoC you're seeing in ABRP matches the LeafSpy SoC?

That means LeafSpy must not be sending us some of the data we use to compute the dashboard SoC.  The reason it doesn't match is LeafSpy by default sends the "raw" SoC, which includes some battery capacity loss, and the reserved battery (generally around 0-10% at the bottom of the battery).  I'm not sure why LeafSpy would be missing some parameters when they send it to us? Perhaps a better question for the LeafSpy developer?

Share this post


Link to post
Share on other sites
9 hours ago, Jason (ABRP) said:

Ah, interesting.  So the SoC you're seeing in ABRP matches the LeafSpy SoC?

No at all.

LeafSpy show 90%, car dash show 95% and ABRP show 98%!

In my leafspy I do not have any config to change the "SOC calculation" or something like that.

 

Share this post


Link to post
Share on other sites
On 8/1/2019 at 3:12 AM, Jason (ABRP) said:

@Jilldris, @JohnT - any thoughts on why @Frankesousa's SoC might be off?

Perhaps gids_min / gids_max is different for Leafs within a battery size? Incremental battery pack changes hidden from the users?

Well as you say @Jason (ABRP) we don't understand exactly how the Dash % is calculated but it corresponds quite ok with the equation used by ABRP. However there is a spreed of several %, up to ~5%, and it is not constant but can differ on the same car from different drives. Eg a deviation of 2-5% seems possible. 

In the plot below is data from Leaf 40kWh where the straight line is the equation used by ABRP. If @Frankesousahave similar data from Leaf30kWh it would be easier to see how it deviates. 

image.thumb.png.1dac86bb15e3afa3abf930102b720390.png

 

Share this post


Link to post
Share on other sites
19 hours ago, Jilldris said:

In the plot below is data from Leaf 40kWh where the straight line is the equation used by ABRP. If @Frankesousahave similar data from Leaf30kWh it would be easier to see how it deviates. 

If you guys want I can try to collect this data, GIDS and leafspy SOC is already collected on the leafspy log I only need to register the dash % from 100 to 10% (if I remember correctly the dash change to --- more or less at 10%).

 

Do you want that I register this for my leaf 30kWh? The current SOH is 86.7%.

Share this post


Link to post
Share on other sites
9 hours ago, Frankesousa said:

If you guys want I can try to collect this data, GIDS and leafspy SOC is already collected on the leafspy log I only need to register the dash % from 100 to 10% (if I remember correctly the dash change to --- more or less at 10%).

 

Do you want that I register this for my leaf 30kWh? The current SOH is 86.7%.

We are some Leaf 24 and 40kWh users that have provided data to improve those models in ABRP. If you want to do the same for 30kWh to improve that model for you and other Leaf 30kWh users we can help with analyzing the data if you want. And Jason is usually very quick with making updates.

Share this post


Link to post
Share on other sites
13 hours ago, Jilldris said:

We are some Leaf 24 and 40kWh users that have provided data to improve those models in ABRP. If you want to do the same for 30kWh to improve that model for you and other Leaf 30kWh users we can help with analyzing the data if you want. And Jason is usually very quick with making updates.

OK. I will collect the data and back to you.

Thank for you help.

Share this post


Link to post
Share on other sites
On 8/6/2019 at 3:16 AM, Frankesousa said:

OK. I will collect the data and back to you.

Thank for you help.

If you can measure the GIDs vs Dash SoC, that'd be the best way to get an accurate model.  I believe we've found the closest correlation between those values.

Share this post


Link to post
Share on other sites
On 8/13/2019 at 4:12 AM, MrThrane said:

I'm now getting: Could not retrieve token

What is up with that? 

Sorry I missed this, was out of town at the time, did you ever manage to retrieve a token?

Share this post


Link to post
Share on other sites
4 hours ago, Jason (ABRP) said:

Sorry I missed this, was out of town at the time, did you ever manage to retrieve a token?

Yeah. Needed to be on a computer to see a token. Was something wrong when doing it via mobile phone. 

Share this post


Link to post
Share on other sites
On 6/26/2019 at 3:04 AM, Goodbar said:

Cool, thanks for the tip. I'd forgotten about split screen, honestly. Never had a good use for it until now, apparently.

Even in split screen you need to "select" the leafSpy by tap on it part of the screen. If you tap on ABRP part the leafspy will stop to send data to server.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...