Jump to content
green light

Strange routing with useless 50km

Recommended Posts

Description: Routing does not take the shorted way to a charger/waypoint but routes to an additional charger 25km away and back.
 
 
Replication Steps:
 
So in this plan, the charger at "Kaufland" is selected and after that "Pforzheim Nord". The shorted way would take at the marked crossing in the picture the direct way north. But routing decides to go south, take the Allego charger and then route the same way back to Pforzheim Nord charger. This happens only if the final destination is far away. If it is "too close", routing is correct.

Unbenannt.JPG

Share this post


Link to post
Share on other sites

Sounds like the same problem as https://forum.abetterrouteplanner.com/topic/184-unnecessary-charge-is-used/

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah, something has happened to the routing engine. I have a planned trip coming up next month and it was having trouble routing it, kept giving an error or not showing the route, or not showing that it was routing. Now the results are coming back but they are CRAZY different than they used to be. It's got me driving all over the country taking may more days and visiting tons of chargers to make this crazy drive.

367636834_ScreenShot2019-04-11at8_47_46AM.thumb.png.d8ff9a8829d5e4667e7ce6a0fac76099.png

Black lines indicate selected route and charge stops

  -Randy

Edited by israndy

Share this post


Link to post
Share on other sites

If I zoom out it's easier to see. I also X'd out all the chargers it has me visiting for no reason, perhaps it's not days longer but it is quite stranger.

1819859338_ScreenShot2019-04-11at9_18_04AM.thumb.png.d97fa95698b829770df7336bb6e76daa.png

This is my first time reporting a bug this way. So what happens? It doesn't appear too many people get their questions answered this way. But I wasn't really getting them answered via email either.

  -Randy

Share this post


Link to post
Share on other sites

Rest assured we do check these threads, though both Bo and I have day jobs so it's often a little while between when we can check on these bug reports.  Bo's also on a work trip this week, so if you sent these bugs to him, they're probably still sitting in his inbox.

I'm really not sure why it's taking that route, but all those charger stops are entirely unnecessary, you can make it from the first to last charger without any stops at all.

That being said, it does expose some odd behavior in the route finding.  Checking it against the routing engine (no charging stops) the route is planned sensibly, and forcing it to use the road between the second two charging stops resolves the issue:

https://abetterrouteplanner.com/?plan_uuid=145ba690-954a-4cf7-8d59-b720e764be32

image.png.30a8e8e277776f18321851ae1174506e.png

I've added this to our issue tracker and we'll spend a little time trying to figure out why it's taking that route.  In  the meantime, an easy workaround (if you intend to actually drive this route) is to start driving with live data, and then when you deviate from the planned route it'll offer to replan from your current position.  Then once you're replanned, it'll be forced to take the route you're currently driving.

Share this post


Link to post
Share on other sites

Yes, of course, sorry. But while I am mentioning it, what happened to the Plan Route button? It used to change to Cancel Planning or something, and that animation comes up, but it's below the position the window is open to, the only indication that you actually pressed the button is the scroll bar gets a little smaller.

The link is: https://abetterrouteplanner.com/?plan_uuid=7d1080f9-e4b5-4cd2-86fc-49da70d33995

Hope this helps!

Share this post


Link to post
Share on other sites
On 4/12/2019 at 3:08 AM, Jason (ABRP) said:

In  the meantime, an easy workaround (if you intend to actually drive this route) is to start driving with live data, and then when you deviate from the planned route it'll offer to replan from your current position.  Then once you're replanned, it'll be forced to take the route you're currently driving.

Thanks. Indeed, I might have to take this route: the nearby charger is a plan b fall back if first charger is not working. I wanted to check the distance and have ABRP already configured.

Share this post


Link to post
Share on other sites

Sorry for not responding earlier, and great thanks for the specific bug reports! The issue was that the new generation planner avoids chargers which are too close to each other, and we forgot to exclude the case where the chargers were waypoints 🙂

Now fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...