Jump to content
  • 0
A900ss

ABRP and EV Notify in same phone? ABRP keeps crashing

Question

Hi, 

ive only just linked my Ioniq 28 to ABRP live data but I can’t use one phone to do both ABRP and EV Notify. 
 

I have EV Notify in development mode so it can work in the background and want the ABRP app in the foreground but it just keeps crashing (Android App). Is this normal?

the data from EV Notify is working fine in the background because I can use ABRP live data on my iPhone (being fed by EV Notify on the Android) 
 

Ideally I’d rathe have both Apps running on my Android phone. Is this possible with aBRP in foreground?

PS - I didn’t check ABRP via a web browser so that might be an option?

thanks. 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

That's very strange, have you disallowed either app access to your location? We recently tracked down a load of bugs related to non-existent position, but perhaps one snuck through.  Both apps should work just fine together on the same phone.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, A900ss said:

Hi, 

ive only just linked my Ioniq 28 to ABRP live data but I can’t use one phone to do both ABRP and EV Notify. 
 

I have EV Notify in development mode so it can work in the background and want the ABRP app in the foreground but it just keeps crashing (Android App). Is this normal?

the data from EV Notify is working fine in the background because I can use ABRP live data on my iPhone (being fed by EV Notify on the Android) 
 

Ideally I’d rathe have both Apps running on my Android phone. Is this possible with aBRP in foreground?

PS - I didn’t check ABRP via a web browser so that might be an option?

thanks. 

It should normally work (both apps on 1 android phone).

dit you update the abrp app?

and did you have internet access (available to the abrp app)?

do you also have the crashes if only abrp is running? (and evnotify on iphone in foreground)

Share this post


Link to post
Share on other sites
  • 0

Hi, 

I have the phone tethered today my IPhone so it’s always data connected. 
 

I have EV Notify in the the background (with developer setting so it never goes to sleep) and tried to have ABRP in the foreground. 
 

I know EVN was working fine as I could see all the live data on the EVN app in my IPhone but ABRP just kept crashing everytime I restarted it. 
 

I’ll give it a try again later today and see what happens.  I’m fairly sure that both apps are the latest builds.  
 

Both apps do have access to location data. 

Share this post


Link to post
Share on other sites
  • 0

Just went out in the car again and same issue. ABRP crashes on Android when EVN is in background. I sent a report but not sure if that goes to Google or to ABRP?

The data than EVN is feeding is working fine if I use my iPhone ABRP app though. 

Share this post


Link to post
Share on other sites
  • 0

Ok - I’ve worked out what the problem is and I think there is a bug either in ABRP or my phone. 
 

I don’t keep my phone in a cradle for ABRP, I just leave it on the passenger seat so it changes from landscape to portrait view as the phone gets bumped on the seat. That’s fine. 
 

When it changes from Portrait to Lansdcape in the app, it  is fine but when it changes from landscape to portrait, the app crashes. I’ve repeated this test three times and it crashes immediately. This is the issue. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I’ve given up with the ‘one Android phone to run EVN and ABRP plan’. I disabled autorotate on the phone and this has stopped ABRP crashing but the link to my Bluetooth dongle isn’t 100% stable now when I run APRB as well as EVN. It drops off now and then.   I think my Android phone may not be powerful enough to run them both together (Moto G5 on Android 8 ) 
 

I’m now using the Android for EVN and running the ABRP app in my iPhone. 100% stable today and no dropping off from the BT OBD dongle or ABRP crashes. It’s not what I would have wanted but it’s fine. 
thanks. 

Edited by A900ss

Share this post


Link to post
Share on other sites
  • 0

@A900ssyesterday afternoon (CEST 1500-1800) I had the same? issue (ABRP crashing when starting the app). This after 1 year of succesfully using ABRP and EVNOTIFY on a cheap android 8.0 phone.

Strange thing is that a few hours earlier it still worked successfully...

So , You could try a again is a weeks time?

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...