Jump to content

Planner Skipping Chargers

Recommended Posts


For all examples below, I am using my Windows 10 machine and the web planner.

Example 1:

I am still struggling with planning an across the country trip from Portland, OR to the Atlanta, GA area. I pulled this example fragment from the overall plan for simplicity. You can see that the planner ignores the Salt Lake City, UT Supercharger at the expense of a much longer charge at Tremonton, UT and reduced highway speeds.

THEN, adding Salt Lake City Supercharger as a waypoint knocks the Tremonton Supercharger out and moves the same problems (charge time and highway speed) North.

Example 2:

THEN, restoring Tremonton, UT to the charging plan results in the "Out of the Way" routing to Evanston, WY described in my previous posts, including an substantial number of additional and unnecessary miles.

Example 3:

Type: Windows 10 machine and the web planner
Link to Plan: See 3 links above


ABRP Skipping Chargers - 1.png

ABRP Skipping Chargers - 2.png

ABRP Skipping Chargers - 3.png

Link to comment
Share on other sites

I'm not seeing this, but not using superchargers either.  The original poster's examples seem to be working now.  I wonder if it is dependent on the details of the charger being passed.  Could you provide a current example of charger being passed?  I'm still working on how much faith to put in the routes being generated and would like to understand when reduced speeds are used.

Link to comment
Share on other sites

Hi @PDXBob, @stocktroy, @CBenson,

This is actually not a bug but a feature ? 

The settings option is called 'adjust speed' and can be toggled off / on in: Settings (detailed) > Speed

Lowers consumption by lowering speed, thus lowers the number of stops.

When the option is turned on, the legs of the route with reduced speed will be orange and you'll see the details on speed limit in the list of stops. 

However yes, the detour in example 2 doesn't make sense. Likely the planner tries too hard to optimize the SoC for faster charging thus drives further to consume more. Not exactly desirable, we'll have a closer look at this.

Update: we discovered the bug causing this and we've had the issue that resulted in the detour fixed.


Edited by Katya (ABRP)
bug fixed
Link to comment
Share on other sites

I'm seeing a similar problem - ABRP is telling me that I can't make it from Twin Falls, ID to Tremonton, UT despite there being a supercharger in Burley, ID that it is skipping.  I have all real-time conditions turned off, and my settings allow arrival at superchargers with up to 90% of charge.  I also have speed adjusting turned off.  So I can't understand why it would tell me the leg is impossible when it clearly isn't.

This is using the web app in Chrome on Windows 10.


Link to comment
Share on other sites

1 hour ago, PDXBob said:

To clarify, I meant that I have the "Charger max SoC" set to 90% which I originally had set at 70%.  I thought maybe it was calculating that my SoC would have been over 70% when passing that charger and thus skipped it because of that maximum.  But, alas, that change didn't make a difference either.

I did use the waypoint solution, but that seems to defeat the purpose of having ABRP tell you when and where you need to charge for optimal travel...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...