Jump to content

Frontend Planner Error

Recommended Posts

Description: When trying to plan a route on the classic website, an error message "Frontend Planner Error" is returned and the route is not planned (See enclosed file). I have also noticed that on the APP (v3.9.17) when i try planning the same route nothing happens. The Blue arrow goes round for a while and then stops
Type: Message was noticed on Old Classic version (https://abetterrouteplanner.com/classic/). App does not give any error message but does not plan route. For the APP this issue was noticed after the last update
Link to Plan: N/A
Replication Steps:
  1. Enter the details of the starting point
  2. Enter the detail of the destination
  3. Click on plan route
  4. Route is not planned - "Frontend Planner Error" message is displayed. For the APP, nothing is displayed and no route planing takes place

ABRP Planning error.PNG

Link to comment
Share on other sites

Barry hi,

Thanks for getting back promptly.

Using the shared link that you provided, that worked. However when i tried planning again both on the new website (no response) and on the classic website - same error.

On the APP no route plan is shown.

My settings are in the enclosed files. using VW iD3

ABRP Planning error -feedback1.PNG

ABRP Planning error -feedback2.PNG

Link to comment
Share on other sites

Barry hi,

Got it working now on the app, the classic website and on the new website.

I selected a different car - the Hyundai Kona and this provided a planned route. I then re-selected the iD3 and it now gave a planned route. See enclosed files

I think the issue may have to do with selection of the ID3 initially. Can't explain why ?‍♂️ 

Thanks for your time and the inspiration.....

ABRP Planning error success -old.PNG

ABRP Planning error success - new.PNG

Link to comment
Share on other sites

Barry hi,

Just a thought could it be the presence of a "null" value before the ID 3 vehicle name be the reason why the ID3 does not work when used as the selected vehicle? Please see below circled in red.

I have checked for a number of different cars and they work ok. But when i select ID3 it does not work. I have to select it as a "Quick Select" and not use it as a car owned by me.

ABRP Planning error ID3 - new.PNG

  • Like 1
Link to comment
Share on other sites

Ah, an interesting bug! The "Add My Car" feature was built with live data in mind, and this was overlooked.  We'll fix this bug soon.  For now, if you select the standard ID.3 from the list instead of your saved version it should work for planning.

Link to comment
Share on other sites

Jason hi,

A further observation that may help in the resolution. I have tested planning with a number of other vehicles including VW iD4 and they all work when selected from the list.

However for some reason, none of the iD3 models will work both on the new and old websites or on the APP. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...