Jump to content

vag

Members
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

0 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. The zombie state idea sounds like a good path to follow, especially because the AutoPi wakes up every 3 hours, as it is configured actually, so even without using the car, the ABRP script should have at least one update within this interval. But this is not the case.
  2. @Jason (ABRP) After having changed the pid, I can confirm you that it works on the Kona like before.
  3. @Jason (ABRP) Today i tried something to see if the AutoPi wakes-up well on the car power-on. For this I used a power-on trigger that sends me an e-mail when the system boots. So this morning I received it at 7:45, when I powered on the car which is normal. On the other side, the last update that I have on ABRP is dated from yesterday, at 21:17, which is the time when I powered off the car (yesterday). The above means that the AutoPi starts well when the car is ON and powers down correctly when the car is OFF. The script doesn't starts on the same time than the AutoPi. I hope this can help you.
  4. @Jason (ABRP) Thank you for this new version. I uploaded your new version to the car. The script works like previously and the delay is still there. For small distances with the car (about 2km in the city: taking approximately 5-6 minutes with the parking), it doesn't has the time to send the data to ABRP.
  5. Hello @TheRussian, It is indeed a bit too slow at the startup, I don't see exactly why, but the script works well. You need to let it work for a few days in order to better estimate if it works or not. Hopefully we'll find out why soon.
  6. Hi @TheRussian, In the attached picture you have everything you need to make the script work: Variable items that depend on your setup: Name: is the name of the job, put something that reminds you what that job does Function: This is the name of the script, as you saved it in "Advanced" -> "Custom Code" AutoPi screen/menu. The first part is the exact name that you setup in the custom code script creation (I have set my_abrp_iternio) and here you must add the ".tlm" part (at the end of the script's name) Kwargs: Your own token as you see it in my example (replace the xxxxxx...) and at the next line the Kona car_model, exactly like you see it here above. All the rest must be exactly like on the picture here above. You save the cron job and you synchronize it with the AutoPi. After a while, it should start to send data to ABRP. Sometimes, and I don't know the reason why, it takes a little long to start sending the data. But it definitely works.
  7. The AutoPi doesn't takes that long to boot and we can see this by checking its web interface after power on, for instance. So I don't think that the delay could come from that. Anyway, this would be of course a nice improvement, but the script works perfectly for the rest. All in all, having the online info uploaded for very short distances is not that necessary.
  8. Yes, the job is configured to run once every minute and only one job may run at a time. I have some more and positive info: I reality, it needs to run for a while in order to provide the data to ABRP. Because of the actual pandemic limitations, driving a car is only possible for very small distances and this was apparently not always enough to get the data. So I can confirm that the script definitely works, but we need to drive for a few Kms in order to have the results online. Thank you Jason 🙂
  9. @Jason (ABRP) I did some additional tests today and I noticed that the script seems not to run continuously. When I launch the it in the AutoPi's web console followed by my data: token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx car_model=hyundai:kona:19:64:other It works until the next reboot of the AutoPi. When it is configured as a job, it apparently doesn't works. I tried the token & car_model in the Kwargs (and also in the Args), without success.
  10. When you click on this, it gives you your public charger network preferences (never use this network, prefer that network etc). I don't think it is a Kona specific. But maybe if you don't have setup any network preferences, it doesn't shows up.
  11. The PIDs that mean that the Kona is charging are the following: Mode: 21 PID: 01 Header: 7E4 By the way, apparently the script doesn't detects actually when the charging stopped and continues to display the charging sign even when the car has been disconnected from the charger. You can see in the attached picture here that it still looks like if it was charging, which was not exact when that snapshot was taken. Probably checking the above PID can be used to eliminate this issue. Regarding the other cars, I don't have any idea, except that I read somewhere that there are similarities between the Ioniq and Kona, so it could probably work without much modifications.
  12. @Jason (ABRP) Here is a link to a draft page with instructions that I created 🙂 : instructions page Feel free to modify it and use it of course. Regarding the PIDs for the Kona 64, these are the ones that are used to keep the AutoPi awake: Mode: 220 PID: 101 Header: 7E4 They mean that the car is "driving". I hope this can help you. Let me know if you need something else.
  13. @Jason (ABRP) Hi Jason, It finally worked! The problem was only the kwargs setup in the cron job. After a quick check in the code, I noticed that the "abrp_token" was changed to "token" in the last version of the script. Once I did that change in the job, it started working 🙂 I'll check the instructions and add/complete information in there. Let me also check about the PID to keep the car awake and I'll get back to you with it. Thank you again for the good work!
  14. @Jason (ABRP) Hi Jason, I finally found some time to test the last version of the script. When I run it from command line, it uses the test data and prints out back the following : ------------------------------------ "... Running from command line. {'soc': 88.4, 'power': 15.52, 'soh': 100, 'is_charging': 0, 'ext_temp': 20, 'voltage': 388.0, 'lat': 29.5641, 'speed': 113.2, 'batt_temp': 20, 'utc': 1587192573.813606, 'lon': -95.0255, 'current': 40, 'car_model': 'chevy:bolt:17:60:other'} https://api.iternio.com/1/tlm/send?token=test&api_key=6f6a554f-d8c8-4c72-8914-d5895f58b1eb&tlm={"soc"%3A88.4%2C"power"%3A15.52%2C"soh"%3A100%2C"is_charging"%3A0%2C"ext_temp"%3A20%2C"voltage"%3A388.0%2C"lat"%3A29.5641%2C"speed"%3A113.2%2C"batt_temp"%3A20%2C"utc"%3A1587192573.813606%2C"lon"%3A-95.0255%2C"current"%3A40%2C"car_model"%3A"chevy%3Abolt%3A17%3A60%3Aother"} None …" --------------------------------------- Nevertheless, when i run it from Autopi’s terminal web interface, i find the following in minion logs : --------------------------------------- " … 2020-04-18 06:51:31,100 [salt.loaded.ext.module.power:189 ][WARNING ][1817] Using deprecated argument 'enable' - use 'add' or 'clear' instead 2020-04-18 06:51:34,495 [salt.utils.schedule:927 ][ERROR ][1795] Unhandled exception running my_abrp_iternio_v3.telemetry Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/salt/utils/schedule.py", line 842, in handle_func message=self.functions.missing_fun_string(func)) File "/usr/lib/python2.7/dist-packages/salt/utils/error.py", line 36, in raise_error raise ex(message) Exception: 'my_abrp_iternio_v3.telemetry' is not available. ..." --------------------------------------- I don’t see what could cause the unhandled exception, while it works with the test data in ssh terminal screen. The token and car_model are well in the kwargs of the job: by the way, this is very convenient 🙂
  15. The baudrate and protocol are important in my opinion, as if they are wrong in the AutoPi interface, nothing is read from the OBDII. I've added them. I also uncommented the speed at line 247 which is now: 'speed': "220,100,'{30}',7B3", Still not working, no transmission to ABRP. I then replaced (lines from 282 to 288): tlm(test=True,testdata={"soc": 88.4, "soh":100, "voltage":388.0, "current": 40, "is_charging": 0, "ext_temp":20, "batt_temp": 20, "lat":29.5641, "lon":-95.0255, "speed":113.2 }) tlm(test=True,testdata={"soc": 88.4, "soh":100, "voltage":388.0, "current": 0, }) by: tlm(test=False,testdata=None) and still no results. Then I replaced in line 32: get_tlm(test=test,testdata=testdata) by: get_tlm(test=False,testdata=None) without any additional success. I checked minionutil.last_logs and minionutil.last_errors in the AutoPi's web interface, but they don't return anything. When I look in file: /var/log/salt/minion, there is n nothing specific nor any error pointing clearly to your script 😕

Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...