Jump to content

Treborg

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. Description: See ABRP 3.7 provides NaN's for clock times along a calculated route on a 2017 Tesla MX (AP 2.0) running 2019.16.3.2. I verified that the Tesla browser is getting vehicle system time correctly using the website shown in the picture. I now suspect there's a bug in ABRP 3.7 if it runs in the AP 2.0 web browser. I've attached an image of the trip summary table from the Tesla showing the NaN's. Link to Plan: If the bug is in finding a route, please copy the plan link here (found under "Share"). Replication Steps: Open the Web Browser on a Tesla running AP 2.0 hardware and firmware 2019.16.3.2 (mine is a 2017 MX built March 2017) (2019.16.3.2 is essentially the latest firmware release). Using ABRP 3.7 in the browser, plan a trip from the current location to some location a few hours away. Review trip summary table for NaN values in the arrival and departure time columns. Remember, the more detail you can provide in your bug report, the faster we can fix it!
  2. More tinkering. I found a web site that displays time data in a browser obtained from the computer system running the browser. Here's the image: the Tesla web browser is getting correct local time data. I'm now suspecting a bug in ABRP 3.7.
  3. With more tinkering, I've figured out #1 & #2. I'm still stuck on "#3" and the NaN's. I'm now guessing that the vehicle isn't sharing current time data with the vehicle browser for some reason. I'll go search around Tesla forums to see if others have found this issue.
  4. I've tried running the latest version of ABRP (3.7) in the browser on my AP 2.0 car. It seems to run OK, perhaps a bit slow. I have two questions: 1) In a YouTube video from Now You Know done in a Model 3, ABRP popped up a login prompt right after starting up in the browser, and the login feature apparently ties the website to vehicle data & data transfer. I don't see that login prompt in my vehicle. Is that because I'm using an older browser (AP 2.0)? 2) The YouTube video also showed a bunch of customization possible in ABRP running in the vehicle after the login prompt. I don't see any of them in ABRP running in my vehicle. Am I missing some tab/feature that reveals this? 2) I see NaN's in the time of arrival columns for a trip planned in my vehicle. It does show the trip duration time. I don't see the NaN's when planning the same trip on a desktop computer running Firefox & ABRP. Why are the NaN's appearing in the time columns? Is there anything I can do to fix this? Thanks!

Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...