Jump to content

ABRP 3.7 Release Notes

Bo (ABRP)

18,564 views

At ABRP, we work a little bit like a certain EV manufacturer - we release new features and upgrade any time, without much announcement. (Sometimes we break things, too.) However, sometimes it is good to make an announcement of all the things which have happened so that nobody misses the new goodies. Therefore; ABRP 3.7!

  • Next Charger: Press this nifty little button, and you will be given up to five alternatives for your next charger, including how much time each choice will add to your trip. Perfect if you feel like skipping a certain charger, or if conditions change. Or you really need to go to the bathroom.
  • New telemetry/OBD framework: We have updated our way of collecting real-time data for supported car models (which are not always-connected and have an open API like the Teslas). If you want to have real-time car SoC % in ABRP, click Settings->More Settings->Setup to get a guide on how to do.
  • Updated maps: We have updated the maps and changed maps provider. We think they look even better, but let us know if there is anything we can do to further improve. We can definitively change the way they look.
  • New car models: All the new 2019 Teslas are in, including the longerrrr range Model S and X. But also Audi E-tron Sportback, Volkswagen I.D. and many more.

and also don't miss that

  • ABRP plans more than 3 times faster than before in release ABRP 3.6!
  • Like 2
  • Thanks 1


28 Comments


Recommended Comments



Updated maps: 
You did what?! Didnt expect that and didn't see that the whole day.

Getting alot of 404s now on api.maptiler.com if i zoom in too far.

Yes, the naming scheme of Tesla will make it a challenge in the future to get all models in one place...

Share this comment


Link to comment
Guest Nigel

Posted

I have a problem after the new version. Th location of my car is not updating it shows me in the sea to the east of sweden, I am in the UK. Mycar is a model S 2019

Share this comment


Link to comment

Impossible to get live data with last Version of abetterrouteplaner with Kona ev. Sad tomorrow I have a very long trip...

The token set as email in torque is changing everytime I open abetterrouteplaner with a new browser instance and if I use the shortcut from my Android phone then abetterrouteplaner ask me to update everytime ..

The best result I had is a red message saying the unit (obd) must be switched off and the ask to unplug it and switch on another time .

While on torque I have well all info in real-time.

Screenshot_20190427_173937_com.android.chrome.jpg

Share this comment


Link to comment
Guest Gyver

Posted

18 hours ago, Guest Nigel said:

I have a problem after the new version. Th location of my car is not updating it shows me in the sea to the east of sweden, I am in the UK. Mycar is a model S 2019

Same Here with a December 2018 Model S, I'm in France.

Share this comment


Link to comment
Guest Gyver

Posted

Just now, Guest Gyver said:

Same Here with a December 2018 Model S, I'm in France.

I believe the problem appeared with a 2019.x version of the firmware, at least it is present in 201(.12 and was present in 2019.8.4.

Share this comment


Link to comment

I have the same problem with my Ioniq like schtruck. Get no live data from Torque pro, everything is set up as told in the description. 

20 hours ago, schtruck said:

Impossible to get live data with last Version of abetterrouteplaner with Kona ev. Sad tomorrow I have a very long trip...

The token set as email in torque is changing everytime I open abetterrouteplaner with a new browser instance and if I use the shortcut from my Android phone then abetterrouteplaner ask me to update everytime ..

The best result I had is a red message saying the unit (obd) must be switched off and the ask to unplug it and switch on another time .

While on torque I have well all info in real-time.

Screenshot_20190427_173937_com.android.chrome.jpg

 

Share this comment


Link to comment

I believe you're correct that it's an issue with the latest Tesla firmware.  It can be resolved by adding your MyTesla credentials to get location directly from the car API.

21 hours ago, schtruck said:

Impossible to get live data with last Version of abetterrouteplaner with Kona ev. Sad tomorrow I have a very long trip...

The token set as email in torque is changing everytime I open abetterrouteplaner with a new browser instance and if I use the shortcut from my Android phone then abetterrouteplaner ask me to update everytime ..

The best result I had is a red message saying the unit (obd) must be switched off and the ask to unplug it and switch on another time .

While on torque I have well all info in real-time.

 

 

1 hour ago, Nefilim78 said:

I have the same problem with my Ioniq like schtruck. Get no live data from Torque pro, everything is set up as told in the description. 

 

Point of curiosity, did you have Torque connected to your car when you performed the setup? Torque is supremely unhelpful when it comes to telling me what Units it's going to send me.  It only sends the units packet once, and if you already connected and sent the units packet, it often doesn't re-send the packet until it deems a new session has started.

Try backing all the way out of Torque while disconnected from the car, double check the setup instructions (including the PIDs), and then try reconnecting to your car.

Share this comment


Link to comment

@schtruck - The first part of my comment was directed at the two "Guest" commenters discussing the Model S Browser issues.  Did you try the Torque suggestions in my most recent comment?

Share this comment


Link to comment
Guest Lotte

Posted

Hi,

I have the "no units found" error for my Ioniq. I was not connected to the car when I changed the upload settings in Torque (I have used some other settings earlier). I have restarted Torque and the phone, but nothing seems to help. I have also tried to change the unit settings in Torque, imagining that this may cause unit data to be sent... 

Best regards, 

Lotte 

Share this comment


Link to comment

Tried everything, even deleting and reinstalling Torque with all PIDs. Nothings helps, no data. 

Share this comment


Link to comment
Guest Lotte

Posted

Thanks, it works for me now! The red "no units found" error message has disappeared and after connecting to the car and logging out/in on the website, I got the SoC value.

Thank you very much!

Share this comment


Link to comment

Jason the token seems to not move anymore

 

But still not live data on abetterrouteplaner

Check:

 

 

Screenshot_20190429_111647_com.android.chrome.jpg

Screenshot_20190429_111640_com.android.chrome.jpg

Share this comment


Link to comment

But maybe it s because of my configuration.

 

I have a phone plugged to my car on which I have torque pro and I have abetterrouteplaner on my other phone I own in my pocket.

Share this comment


Link to comment

Bah still another ID ,video just started abetterrouteplaner from my shortcut then I just had the message the new versions is available and I pressed yes to  update and just get another ID.

 

Screenshot_20190429_115056_com.android.chrome.jpg

Share this comment


Link to comment

I just retried , I closed chrome on my phone then restarted it and browsed abetterrouteplaner.com then I get another ID.

Login is well done automatically to my account and live data is green too but as the id is not sticked I don t thinking it will work .

 

How do you generate id? 

Share this comment


Link to comment

I found this  issue, when I create shortcut from the Version 3.7 and then I close chrome and run abetterrouteplaner from the shortcut then I have the version 3.6. and it request to update 

 

I tried to clear history and site data from chrome but still same issue

Share this comment


Link to comment

@schtruck - to avoid cluttering up the comments here, I'll send you a PM with some more troubleshooting steps, see if we can get your live data working!

Also, for anyone interested the "ID Token" we're using in lieu of email addresses is generated randomly and then associated with your account.  You can have multiple tokens if you have multiple devices, and each time you load up the instructions or click the little ↻ symbol.  My next step is to provide you with a way to manage those tokens, and revoke old ones if you so desire.

As far as the local "app" version of the site, if you have Android you can pull down from the top on any static (not-map) portions of the UI and it should refresh the page and pick up any updates, if the "request to update" doesn't work.  Sometimes if it's been a long time since I refreshed the site starts to get a little weird (live data stops updating, map tiles don't fetch, etc) so I have to refresh anyway.

Share this comment


Link to comment
Guest azozobcs

Posted

I have an idea : Maybe color speed route :)

Share this comment


Link to comment
Guest Duffman

Posted

Is there any way to set maximum charge % at charging stations ? So that you always charge to 80% for example at charging stations along the way

Share this comment


Link to comment
On 4/29/2019 at 12:16 PM, schtruck said:

I found this  issue, when I create shortcut from the Version 3.7 and then I close chrome and run abetterrouteplaner from the shortcut then I have the version 3.6. and it request to update 

 

I tried to clear history and site data from chrome but still same issue

Yes, there seems to be a few bugs in both iOS Safari and in Chrome when it comes to offline caching (which is required for a "Progressive Web App", which you can install on the home screen). 

We have tried to work around this bug now. To be able to load the new version, you may have to go to iOS settings->Safari->Clear web site data.

Share this comment


Link to comment

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Contact Us

Bo - Lead Developer and Tesla owner: bo@abetterrouteplanner.com

Jason - New Car Models, Developer and Bolt owner : jason@abetterrouteplanner.com

Idreams - Forums Administrator, Forums Developer and Tesla owner : idreams@abetterrouteplanner.com

×
×
  • Create New...